aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorDeterminant <tederminant@gmail.com>2020-09-24 13:32:19 -0400
committerDeterminant <tederminant@gmail.com>2020-09-24 13:32:19 -0400
commitf8c07b16a9a3366260052434dec126557ea2e173 (patch)
treea3b8bc2e0d0127272a4abb6ec280e52ec07baf3d /Cargo.toml
init
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml36
1 files changed, 36 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..17b3be0
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,36 @@
+[package]
+authors = ["Determinant <tederminant@gmail.com>"]
+edition = "2018"
+readme = "README.md"
+name = "cessna-knobox"
+version = "0.1.0"
+
+[dependencies]
+cortex-m = "0.6"
+cortex-m-rt = "0.6"
+cortex-m-semihosting = "0.3"
+cortex-m-rtic = "0.5"
+panic-halt = "0.2.0"
+panic-semihosting = "0.5.3"
+nb = "0.1.2"
+embedded-hal = "0.2.3"
+heapless = "0.5.1"
+rand_core = "0.4"
+usb-device = "0.2.4"
+
+[dependencies.stm32f1]
+version = "0.8.0"
+features = ["stm32f103", "rt"]
+
+[dependencies.stm32f1xx-hal]
+version = "0.6.1"
+features = ["stm32f103", "rt", "stm32-usbd"]
+
+[[bin]]
+name ="knobox"
+path = "src/app.rs"
+
+[profile.release]
+codegen-units = 1 # better optimizations
+debug = true # symbols are nice and they don't increase the size on Flash
+lto = true # better optimizations