aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDeterminant <ted.sybil@gmail.com>2019-12-05 16:15:30 -0500
committerDeterminant <ted.sybil@gmail.com>2019-12-05 16:15:30 -0500
commit347daceced3a516fec8080e0fe640f68c137db76 (patch)
tree01695e304609c312acfe5ef80f64af97ab8a8c43 /CMakeLists.txt
parenteba2e398333ec54d21cfa24b61e1bc7de6242f00 (diff)
use pipe to emulate eventfd on mac; add install scriptv0.1.0c
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 29a99ff..c0769dc 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -48,10 +48,12 @@ if(BUILD_SHARED)
add_library(salticidae_shared SHARED $<TARGET_OBJECTS:salticidae>)
set_target_properties(salticidae_shared PROPERTIES OUTPUT_NAME "salticidae")
target_link_libraries(salticidae_shared uv crypto ssl pthread)
+ install(TARGETS salticidae_shared DESTINATION lib)
endif()
add_library(salticidae_static STATIC $<TARGET_OBJECTS:salticidae>)
set_target_properties(salticidae_static PROPERTIES OUTPUT_NAME "salticidae")
target_link_libraries(salticidae_static uv crypto ssl pthread)
+install(TARGETS salticidae_static DESTINATION lib)
option(BUILD_TEST "build test binaries." OFF)
if(BUILD_TEST)
@@ -73,3 +75,5 @@ configure_file(src/config.h.in include/salticidae/config.h @ONLY)
set(CMAKE_CXX_FLAGS_RELEASE "${CMAKE_CXX_FLAGS_RELEASE} -W -Wall -Wextra -pedantic -Wsuggest-override")
set(CMAKE_CXX_FLAGS_DEBUG "${CMAKE_CXX_FLAGS_DEBUG} -W -Wall -Wextra -pedantic -Wsuggest-override")
+
+install(DIRECTORY include/ DESTINATION include)