aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDeterminant <tederminant@gmail.com>2018-07-25 12:20:07 -0400
committerDeterminant <tederminant@gmail.com>2018-07-25 12:20:07 -0400
commit1b006d5164c605ef44652b4442309983bfc0d24a (patch)
tree096c6fe702888850d4bf08cf682579f73a2e9479 /CMakeLists.txt
parentcd2fc3625d09f2f3f062648ff9963414e0140e2a (diff)
...
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index cc6ce86..c004fd8 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -51,9 +51,11 @@ if(NOT CMAKE_BUILD_TYPE AND NOT CMAKE_CONFIGURATION_TYPES)
set(CMAKE_BUILD_TYPE "Release")
endif()
-if(CMAKE_BUILD_TYPE STREQUAL "Debug")
+option(SALTICIDAE_ENABLE_DEBUG_LOG "enable debug log" OFF)
+option(SALTICIDAE_ENABLE_NORMAL_LOG "enable regular log" ON)
+if (SALTICIDAE_ENABLE_DEBUG_LOG)
add_definitions(-DSALTICIDAE_DEBUG_LOG)
-elseif(CMAKE_BUILD_TYPE STREQUAL "Release")
+elseif(SALTICIDAE_ENABLE_NORMAL_LOG)
add_definitions(-DSALTICIDAE_NORMAL_LOG)
endif()