summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml22
1 files changed, 22 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..332dd58
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,22 @@
+[package]
+name = "bluepill-ds3231"
+description = "Test the communication with DS3231"
+authors = ["Ted Yin <tederminant@gmail.com>"]
+keywords = ["no-std", "arm", "cortex-m", "stm32"]
+license = "GPL-3.0"
+version = "0.1.0"
+
+[dependencies.stm32f103xx]
+features = ["rt"]
+version = "0.7.2"
+
+[dependencies.cortex-m-rt]
+version = "0.3.5"
+features = ["abort-on-panic"]
+
+[dependencies.cortex-m]
+version = "0.3.0"
+
+[profile.release]
+debug = true
+lto = true