aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDeterminant <ted.sybil@gmail.com>2018-11-27 18:09:44 -0500
committerDeterminant <ted.sybil@gmail.com>2018-11-27 18:09:44 -0500
commitcef09a1b9dd2197addd4f063fd6c81a2ba7d79e1 (patch)
treecd9b3c62b090ce3ca57c4316d88fdaa68fecdfed /CMakeLists.txt
parent59bac78c30b88b4a4db75b906c20f2bfe35ded41 (diff)
add license info for each source file
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt15
1 files changed, 15 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a443e8f..a9df6ef 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,3 +1,18 @@
+# Copyright 2018 VMware
+# Copyright 2018 Ted Yin
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
cmake_minimum_required(VERSION 3.9)
project(hotstuff)
set(CMAKE_CXX_STANDARD 17)