aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDeterminant <ted.sybil@gmail.com>2019-05-09 22:08:54 -0400
committerDeterminant <ted.sybil@gmail.com>2019-05-09 22:08:54 -0400
commita32f1af24dbc7e5d3da51d174532eaa923cd4f26 (patch)
tree6581a1fb54fe3d274c76dddc59fb845273b16945 /CMakeLists.txt
parent0ec28b0d659836a5fb32702cdee8c3433727f48f (diff)
support both two-step and three-step HotStuff
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a9df6ef..2a3209e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -78,6 +78,7 @@ option(HOTSTUFF_NORMAL_LOG "enable normal log" ON)
option(HOTSTUFF_PROTO_LOG "enable protocol log" OFF)
option(HOTSTUFF_MSG_STAT "eanble message statistics" ON)
option(HOTSTUFF_BLK_PROFILE "enable block profiling" OFF)
+option(HOTSTUFF_TWO_STEP "use two-step HotStuff (instead of three-step HS)" OFF)
configure_file(src/config.h.in include/hotstuff/config.h @ONLY)