aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDeterminant <tederminant@gmail.com>2018-07-26 14:54:21 -0400
committerDeterminant <tederminant@gmail.com>2018-07-26 14:54:21 -0400
commit5f00c067f863f812a740dc209b1fb829f04042eb (patch)
tree1a4452299d729d9cd5c75871c2fdc32f2ee45564 /CMakeLists.txt
parenta3f76ac9bb539ba55431cc74f5de09653185cdef (diff)
add auto generated config.h
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 1 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ca4d39d..0e65e00 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -58,11 +58,7 @@ endif()
option(HOTSTUFF_ENABLE_DEBUG_LOG "enable debug log" OFF)
option(HOTSTUFF_ENABLE_NORMAL_LOG "enable normal log" ON)
-if(HOTSTUFF_ENABLE_DEBUG_LOG)
- add_definitions(-DHOTSTUFF_DEBUG_LOG)
-elseif(HOTSTUFF_ENABLE_NORMAL_LOG)
- add_definitions(-DHOTSTUFF_NORMAL_LOG)
-endif()
+configure_file(src/config.h.in include/hotstuff/config.h @ONLY)
# add executables